Windows Phone 8.x will not display *.infopop.cc*

Product: Eve Community

Hi

I have confirmed with several people that when using Windows Phone operating system 8.0 or later sites that end with

 

*,infopop.cc

   or

*.infopop.cc/eve

 

pages will not display.

 

That includes my site:

http://bose.infopop.cc/eve

and another site I just tried

http://alzheimers.infopop.cc/eve

 

We've tried several different browsers on different Windows phones. We get the same result.

 

One browser reports

Can't download file

Windows Phone doesn't support this file type

 Another reports

Search for app in the Store?

You need to install an app for this task

Would you like to search for one in the Store?

 

 

Another browser gave this error message

Error

HTTP 406 Not acceptable

 

Please fix this. Since this seems to affect other Eve sites, I don't think there's anything I can do at my end.

 

Thanks!

 

 

Original Post

Activity Stream

Hi Brian,

 

Thanks for your reply.

Your suggestions below (and toggling all the other options on the phone) did not make a difference.

Windows Phone 8 that can happen on many websites (and has happened on some major websites like YouTube even). Some users have suggested trying to change the browser's settings from "Desktop version" to "Mobile version" to see if that helps. If the issue persists, the best course of action is probably to contact Microsoft support. The "Search for app in the Store?" option is a "feature" (perhaps more accurately a "nuisance") built-in to the browser. I have no idea what criteria the browser uses to determine if that prompt should be displayed or not. Microsoft should know, and they don't seem to have much documentation explaining how/why they have this behavior in their mobile browser.

 

Another thing people suggest to try is to clear the browser's history (cookies, passwords, websites) and reboot the phone to see if that helps.

 

Hopefully one of these tricks works to get around Microsoft's browser issues!

 

Regards,

 

Brian

I'm using all the usual popular sites on my phone without issues. (that includes youtube).

 

Could you look into the HTTP response 406 aspect?

 

The suggestion I got from Microsoft support was to double check that the mime types were all supported at the server end.

 

ST

 

Hi ST,

 

What browser you are using to get that 406 error message? What is the request that is causing the 406 message? Do you have a URL? I can tell you that we haven't received any other reports of that issue, and Eve should be supported without issue by all modern web browsers.

 

I also don't see any indications of a single 406 response from the server in your bose.infopop.cc logs. So, it seems odd that your browser is giving that message if there's no indication of that error on the server...

 

Brian

Hi Brian,

 

Thanks for the reply.

 

Pages that will not display

http://bose.infopop.cc/eve/forum

or any other url that contains *.infopop.cc

 

That includes public pages as well as the admin pages.

 

I have tried the built-in IE browser, and also

UC Browser and

Mini Browser

None of them will display the page.

 

Mini Browser reports that there are issues loading the page and recommends checking Wi-Fi and Network settings.

 

There is also a Nokia browser called Xpress.

This is the one that reports

Error

HTTP 406 Not acceptable

Does that help?

 

I don't know anything about the Nokia Xpress browser, but given that it's the only browser giving that error, I'm inclined to think that it's an issue particular to that browser. You might contact their support to find out why they might be reporting a 406 Not acceptable error when one is not being returned by the server. That's definitely odd and inexplicable behavior.

 

For what it's worth, I don't think that the domain name (*.infopop.cc) has anything to do with this issue. You can see from the example I linked that the domain name is different (which I'm guessing would give you the same issue).

 

We have investigated this fairly extensively previously, and unfortunately, Microsoft is not at all transparent in this magical behavior that they are performing. They don't give any indication why their browser gives a "Search for app in the Store?" error message. If you search online for that issue, you'll see many other web developers confused about how/when/why Microsoft chooses to give that message. Without knowing why, it's hard for developers and operations teams to "fix" or change the behavior.

 

As you know, the Eve community platform has been successfully serving pages to all popular web browsers without issue for well over a decade. Given that nothing has changed in this regard with our web service and that it works in every other modern browser, it seems to me that the responsibility for this issue lies primarily with the Windows Phone browser software. We would fix any issues that are within our control, but we've been unable to identify any as of yet.

 

Is Microsoft support able to provide more concrete suggestions as to what the issue might be? Their generic "double check that the mime types were all supported at the server end" response is unfortunately not very helpful to us

Hi Brian,

 

This is the explanation that I found for "Search for App in the Store"

 

That dialog appears when you try to launch a URI scheme or file type for which there is no handler installed on the device. Either the web page is attempting to navigate to a URI with an unrecognized scheme (mycustomscheme:some_parameters) or it's trying to download a file with an unrecognized file extension (somefile.myfiletype).

 

For what it's worth, I don't think that the domain name (*.infopop.cc) has anything to do with this issue. You can see from the example I linked that the domain name is different (which I'm guessing would give you the same issue).

I agree - it's not (the letters in) the domain name, but I assumed that if these sites were all served by you and that this was a point of commonality.

 

And I'm sure that the problem is not exclusive to your sites, but it is reproducible. I've got several people looking at this and it's a common experience. I'm wondering if there's something in the HTTP header that I can't see when I view the source of a page.

 

Here's something interesting.  I can see this.

 

http://bose.infopop.cc/eve/for...Y/7224-01-gen_ii.png

 

(that's an image I uploaded to the forum). I'm guessing at there's no HTTP header in there.

 

Does that help?

That image is served with nearly identical HTTP response headers as what Eve requests use. The only real difference is the Vary header and the content specific differences (type, encoding, length). These are all very standard headers that shouldn't cause any issue.

 

Eve only uses a single URI scheme (HTTP), so I don't see how that could be the issue. Additionally, it shouldn't be trying to download a file when just making a standard web request to your Eve community.

 

The only reasonable explanations that I can see are:

 

1) The Windows Phone 8 browser is passing different HTTP headers that is causing some kind of different response from Eve.

 

2) The Windows Phone 8 browser is not handling a standard, basic HTTP response.

 

#2 seems like the most likely possibility, though I wouldn't rule out option #1 yet.

 

It's definitely weird that changing the browser from the Standard to Mobile (or vice versa) didn't make any impact as it has for other customers in the past.

 

We'll continue to look into this to see if there's anything within our control that can be done...

Hi ST,

 

Our support site here is running Hoop.la, which is a completely different platform, so that's why it should work just fine on your phone.

 

We have identified the root of the issue, however, and we believe it is something that we can fix with a software update. We'll see about getting an update pushed out for that.

 

Note: you may still be able to avoid the issue by changing your browser settings from the Mobile version to the Desktop version in Internet Explorer. It looks like IE has an issue with updating that setting, however, so to ensure the setting works fully, you will need to make sure that you kill/quit the app. Once you have changed to the Desktop verison, you will need to make sure that IE fully restarts. To do so, when you exit the app, you should be able to hold down on the back arrow until you see the currently open app windows. Scroll to the Internet Explorer window and hit the X to close it. Then, you should be able to launch the app and your site should work.

 

If it's still not working at that point, then you'll need to wait for our software update to fix this issue.

 

Can you tell me what phone and model you are using?

 

Thanks,

 

Brian

Hi Brian,

Thanks for sticking with this with me. I really appreciate it.

 

I have changed to the Desktop version, did as you suggested, The page http://bose.infopop.cc wouldn't load. So I rebooted the phone and checked that the setting for Desktop version persisted, and it had, but the page still wouldn't load. Okay - we knew that was a possibility.

 

In the meantime, I'll have to carry around a tablet until you do an update.I'm not looking for a hard commitment here, but could you give me a rough idea how long that might be? I need to make arrangements for the tablet and knowing how long I need to have that would be really helpful.

Can you tell me what you found was the root problem? I'd like to pass that back to the other people I had looking at this.

 

Thanks!

 

ST

My phone is a Nokia Lumia 1024

Windows Phone 8.1 OS version 8.10.12397.895

(Desktop version does NOT work).

 

We've observed the same issue with a Nokia Lumia 625

Windows Phone 8.0 OS version 8.0.10517.150

but on this one switching to the Desktop version DOES work.

Hi Brian,

 

That's great news!

 

Is there anything I can tell the other folks who researched this with me about the root cause? That would get back to Microsoft and could be helpful to pass on to others.

 

Thanks!

ST

Hi ST,

 

The issue had to do with some legacy browser code in Eve that was trying to "smartly" detect certain WAP/WML browsers so that it could serve WML content instead of HTML (with a different Content-Type). Some of the Windows Mobile 8 phones were triggering false positives on that check, which was causing the app issue.

 

We just pushed out a fix for this. Can you try again now in all of your Windows Phone browsers and see if the issue is resolved?

 

Thanks,

 

Brian

Hi Brian,

 

Thank you for dealing with this SO fast. This is great.

 

My Nokia Lumia 1024

Windows Phone 8.1 OS version 8.10.12397.895

 

Is working in both Mobile and Desktop modes.

 

I'll check on other phones and let you know if there are any other issues.

 

 

Thank you!

Add Reply

×
×
×
×